Tuesday Mar 26, 2024

  Operational

BibliU Admin website is unavailable
Resolved

The service went down due to a configuration error. This has been corrected and service restored.

Mar 26, 2024 - 05:02PM (UTC)
Identified

https://admin.bibliu.com is currently unavailable. We are working to bring it back as soon as possible.

Mar 26, 2024 - 04:54PM (UTC)

Components affected

Institution Integrations

Reported on

Tue, Mar 26, 2024 4:58 PM (UTC)

Resolved at

Tue, Mar 26, 2024 5:02 PM (UTC)