Tuesday Feb 06, 2024

 Degraded performance

Students may see previously expired titles in their libraries
Resolved
The fix has been correctly rolled out and students should see the expected collection of titles in their libraries. We apologise for any issues this might have caused.
Feb 06, 2024 - 03:41PM
Identified
We are aware of an issue where plan expiry dates have been extended for all current titles. The result is that some students may see or have access to titles that have been previously expired from their libraries. We are currently rolling out a fix that will resolve this shortly and will cause previous titles to disappear again. Further updates to follow.
Feb 06, 2024 - 10:40AM

Components affected

Student Interface

Reported on

Tue, Feb 6, 2024 10:40 AM (UTC)

Resolved at

Tue, Feb 6, 2024 3:41 PM (UTC)